New Safari Version??

I’ve just spent the last 40 minutes on the phone with Union Bank tech support because for the past 2 weeks I’ve been unable to log in to my online account with Safari. After all this time the tech support person, who was very nice, told me I was missing a patch to Safari.
I told him I have the latest patches to my OS and I am running the most currently available version of Safari. I told me that someone there “got some update patch and could log in.” I told him, with all due respect, I’ve been using Macs for over 20 years. (I got my first Mac 128K in 1985) I was quite certain that there is no more currently available version of Safari. Naturally I ran Software Update and no updates are available.
Currently I’m running OS 10.6.3 and Safari Version 4.0.5 (6531.22.7), according to the About box. I’m not sure why they want to blame Apple, but for their logic to hold true a single user of theirs seems to have a “more up-to-date” version of Safari than is obtainable from either Software Update or Apple’s site.
Fortunately Firefox still works.

Filed under: computer, mac-osxTagged with: , ,

2 Comments

  1. This from Union Bank’s site regarding online banking.

    3.2 Compatible browsers for Macintosh:

    • Mozilla Firefox (currently the optimal choice for our site)
    • For OS X: Microsoft Internet Explorer 5.2.3 with 128-bit encryption
    • The Macintosh SafariTM browser is not compatible with our site
    • Macintosh users are supported on a best-effort basis

    Fabulous.

  2. It seems it’s now fixed. 🙂


Comments are closed for this article!